moodlite

moodlite => moodlite Software => Topic started by: lukilug on May 12, 2019, 10:49:08 AM

Title: Problem compiling new V3.0 Software
Post by: lukilug on May 12, 2019, 10:49:08 AM
Hello,
I tried to update my NodeMCU to the newest software version.
But when I try to compile/upload the sktech I get the following error:
Code: [Select]
Moodlite:419:7: error: invalid use of member function (did you forget the '()' ?)

   len = length;

       ^

Moodlite:420:30: error: cannot convert 'String::buffer' from type 'const char* (String::)()const' to type 'void*'

   memcpy(buffer, data, length);

                              ^

Moodlite:421:16: error: invalid types '<unresolved overloaded function type>[unsigned int]' for array subscript

   buffer[length] = 0;

                ^

exit status 1
invalid use of member function (did you forget the '()' ?)

I already deinstalled the Arduino IDE completely (also deleted the Appdata and Documents folder to get a clean fresh installation) and reinstalled it.
All needed libraries are installed and uptodate.

Does someone has an idea how to fix this problem?
Thanks for you help ;D
Title: Re: Problem compiling new V3.0 Software
Post by: sk8t3r on May 13, 2019, 02:00:18 PM
I have same problem, try restarting Arduino IDE and upload it again. If it will not solve the problem, try instal esp8266 in lower version..
Hope it will work for you! :)
Title: Re: Problem compiling new V3.0 Software
Post by: tomoxm on May 22, 2019, 06:48:52 PM
same issue here, followed wiki on github, have arduino version 1.8.9

UPDATE: version of ESP8266 2.5.0 worked (dont forget to restart arduino)
Title: Re: Problem compiling new V3.0 Software
Post by: OnlyBjarne on May 26, 2019, 11:22:54 PM
Have anyone tried to fix this in platformIO?
Title: Re: Problem compiling new V3.0 Software
Post by: muffintime on June 27, 2019, 10:39:11 PM
same issue here, followed wiki on github, have arduino version 1.8.9

UPDATE: version of ESP8266 2.5.0 worked (dont forget to restart arduino)

How do you use 2.5.0 instead of 2.5.2? I can't find anything on this
Title: Re: Problem compiling new V3.0 Software
Post by: tomoxm on June 27, 2019, 10:41:51 PM
i'm not at the computer, but you can change it where you installing, just choose another version
Title: Re: Problem compiling new V3.0 Software
Post by: muffintime on June 27, 2019, 10:53:30 PM
It never gave me the option for this, since you use the 'additonal boards manager URLs' and it defaults to 2.5.2....Unless I'm really missing something here

EDIT: I was missing something here. Looks like I glazed over this part where you can install a different version in the boards manager. Thanks for the help!
Title: Re: Problem compiling new V3.0 Software
Post by: koron on August 09, 2019, 09:33:04 PM
see picture