News

moodlite - Coming soon


Loading the Right Settings

Cotton728 · 531

Cotton728

  • Newbie
  • *
    • Posts: 4
    • Likes: +0/-0
    • View Profile
on: April 17, 2020, 05:58:46 PM
In following the guide "Preparing Arduino IDE," I get to the last step of matching the settings, and I have the following options which do not match.  What am I doing wrong?



NickNonsense

  • Newbie
  • *
    • Posts: 6
    • Likes: +0/-0
    • View Profile
Reply #1 on: April 18, 2020, 09:07:29 PM
the esp2688 version number in the board manager. You need to select the same version number as you see it in the screenshot, version 2.4 I think this is what I have done to correct mine if I remember correctly.





Cotton728

  • Newbie
  • *
    • Posts: 4
    • Likes: +0/-0
    • View Profile
Reply #2 on: April 18, 2020, 11:10:06 PM
Thank you, I was able to get  all of the settings to match now,  but I get these errors when I try to verify/upload the sketch.


Arduino: 1.8.12 (Windows 7), Board: "NodeMCU 1.0 (ESP-12E Module), 80 MHz, Flash, 4M (1M SPIFFS), v2 Lower Memory, Disabled, None, Only Sketch, 115200"

Moodlite:36:26: fatal error: ESPAsyncTCP.h: No such file or directory

  #include <ESPAsyncTCP.h>

                          ^

compilation terminated.

exit status 1
ESPAsyncTCP.h: No such file or directory





NickNonsense

  • Newbie
  • *
    • Posts: 6
    • Likes: +0/-0
    • View Profile
Reply #3 on: April 19, 2020, 10:49:16 AM
Have you followed this https://github.com/spigotx/Moodlite/wiki/Preparing-Arduino-IDE and downloaded the extra libraries on the page and added them? or maybe search for them in the board manager?

I can't remember exactly what I did now as I was having trouble getting this uploading and working, due to my lack of experience with the hardware and Arduino



 


SMF spam blocked by CleanTalk